[LibreOffice] Fórmula Matricial (Atualizado)

O PROCV é usado para buscar a informação em uma matriz utilizando apenas uma variável, quando é necessário efetuar uma soma ou uma contagem com duas ou mais variáveis, pode-se utilizar as fórmulas matriciais.

Atualização (17/02/17): Comecei a utilizar planilhas para análise maior de dados, passei a observar que o uso de forma demasiada da fórmula matricial como indicado abaixo compromete o desempenho do software. Indico que utilizem a fórmula SOMASES em substituição a indicada. Informação adicional: a fórmula matricial é mais complexa do que explicado neste post, para entender o conceito e utilização mais correta, visitem o site de ajuda do LibreOffice .

Como se utiliza:

  • Para somar valores de uma coluna

= SOMA ( SE ( intervalo_variaveis_1 = valor_procurado_1 ; SE ( intervalo_variaveis_2 = valor_procurado_2 ; SE ( intervalo_variaveis_3 = valor_procurado_3 ; intervalo_soma; 0 ))))

  • Para contar valores de uma coluna

= SOMA ( SE ( intervalo_variaveis_1 = valor_procurado_1 ; SE ( intervalo_variaveis_2 = valor_procurado_2 ; SE ( intervalo_variaveis_3 = valor_procurado_3 ; 1 ; 0 ))))

Esta é a tabela que utilizei para demonstrar o resultado final da fórmula, como exemplo. Meu objetivo foi preencher os dados abaixo com as duas fórmulas, de soma e de contagem, buscando a informação da cidade e ano para preencher os dados.

A tabela dos dados original (busquei informações no IBGE) para usar como exemplo. Os dados da região ficam na parte da coluna acima – em amarelo, e o ano na coluna em verde.

A fórmula da Soma ficou assim:

{=SOMA(SE(Tabela.D$2:I$2=$A2;SE(Tabela.$B3:$B129=$B2;Tabela.$D$3:$I$129;0)))}

  • Intervalo de variáveis 1 – Tabela.D$2:I$2
  • Valor procurado 1 – $A2 (nesta fórmula = Recife)
  • Intervalo de variáveis 2 – Tabela.$B3:$B129
  • Valor procurado 2 – $B2 (nesta fórmula = 2006)
  • Intervalo de Soma – Tabela.$D$3:$I$129. Quando é encontrado as duas condições no intervalo de soma, ele efetua a soma dos valores encontrados.

A fórmula da contagem ficou assim:

{ =SOMA(SE(Tabela.D$2:I$2=$A2;SE(Tabela.$B3:$B129=$B2;1;0)))}

  • Intervalo de variáveis 1 – Tabela.D$2:I$2
  • Valor procurado 1 – $A2 (nesta fórmula = Recife)
  • Intervalo de variáveis 2 – Tabela.$B3:$B129
  • Valor procurado 2 – $B2 (nesta fórmula = 2006)
  • Intervalo de Soma é substituído por 1, quando encontra as duas condições no intervalo de soma, ao invés de somar o valor, ele conta a quantidade vezes que o valor se repete.

Dicas importantes:

  • Por se tratar de uma formula matricial, é necessário ao terminar de redigir, apertar “Ctrl + Shift + Enter” para inserir as chaves no início e no final da fórmula.
  • A fórmula deve sempre terminar o valor dos intervalos na mesma linha, ou seja, no primeiro exemplo a segunda condição e o intervalo de soma terminam no mesmo número (129)

Formula_Matricial

Compartilhe este post:

2 Comments

Deixe uma resposta

O seu endereço de e-mail não será publicado. Campos obrigatórios são marcados com *